≡ Menu

cforms II in italiano

download

Sono disponibili per il download i file per la localizzazione in lingua italiana del plugin cforms II sviluppato per la piattaforma di WordPress da Oliver Seidel.

Affinché l’operazione di aggiornamento possa avvenire con successo, suggerisco una attenta lettura delle istruzioni presenti nella cartella cforms-it_IT scaricabile qui sotto.

NOTA: cforms é stato rimosso da wordpress.org in seguito alla pubblicazione di questo articolo. Gli aggiornamenti futuri del plugin saranno disponibili esclusivamente nella pagina principale di cforms. Il forum di supporto é nuovamente disponibile.

  • Un grazie particolare a Roberto Scano per il prezioso contributo di aggiornamento dalla versione 12.2 italiana alla 14.0.

Localizzazione:

versione 14.1

(100% GPL compliant)

Download

cforms II in italiano { Versione 14.1 | file ".zip" | 128.59 kB | Last Updated 11-04-2012 | 10503 hits }

Informazioni utili per l’installazione:

  1. Traduzione italiana del plugin cforms II
  2. Screenshot per l’aggiornamento dei file
  3. Screencast di supporto
  4. Nota: decidessi di effettuare l’aggiornamento automatico del plugin con la funzione di WordPress, assicurati di effettuare il backup di tutti i campi che hai personalizzato poichè i file verranno sovrascritti.
  5. Nota per la versione 8.5 e superiore di cforms (aggiornamento-automatico) Per aggirare il problema di sovra-scrittura dei file personalizzati proprio alla funzione di aggiornamento automatico dei plugin di WordPress (CSS, ecc.) cforms supporta da ora la possibilità  di allocare una cartella utente personalizzata sotto /plugins/. Crea dunque la nuova cartella a nome cforms-custom e posizionala sotto /plugins/ ricordandoti di spostare in essa i file del tuo CSS (incluse le immagini!), le font, lo sfondo del CAPTCHA, ecc.
  6. allocare il file it.js nella cartella “langs” sotto cforms\js\
  7. Nota: dalla versione 8.6.1, i plugin Comment Luv, Subscribe To Comment e WP Ajax Edit Comments sono completamente compatibili con cformsII.
  8. Nota: dalla versione 9.0, il plugin necessita che sia presente il file abspath.php. Qualora non venisse generato in automatico, inserirlo sotto /wp-content/plugins/cforms/
  9. Nota: dalla versione 10.0 non sarà  piú necessario sostituire i file immagine in inglese allocati nella sotto-cartella /images
  10. Nota: cforms é stato rimosso da wordpress.org. Gli aggiornamenti futuri del plugin saranno disponibili esclusivamente nella pagina principale di cforms II
  11. Nota: dalla versione 10.5 é necessario PHP 5
  12. Nota: dalla versione 10.6 il plugin é nuovamente operativo con PHP 4
  13. Nota: Major Update e supporto PHP 6
  14. Nota: Compatibile WordPress 3.0
  15. Nota: Compatibile WordPress 3.2 o superiore
  16. Nota: Compatibile WordPress 3.3 o superiore

cforms II

Versione: 14.1
Ultimo aggiornamento: Aprile 2012
Versione minima di WordPress: 3.3.x
Compatibile sino alla: 3.3.1

Comments on this entry are closed.

  • gidibao 15 aprile 2010, 14:04

    Ottima notizia Gianluca!!! ;-)

    Grazie a te per il feedback.

    Happy Blogging

    Gianni

  • Gianluca 12 aprile 2010, 20:59

    Già che ci sono…aggiungo un problemino che sto riscontrando in questo momento.
    Avevo impostato come stile cforms.css, personalizzandolo con i colori e basta. Siccome non mi soddisfaceva l’impaginazione ho provato a cambiarlo ma ora non mi attiva altri stili…com’è possibile? Mi sembra molto strano questo…

    • gidibao 13 aprile 2010, 18:48

      Cosa intendi con “non mi attiva gli altri stili”?

      a. Bacheca/cformsII/Stile nella sezione “Seleziona uno stile per il modulo” alla voce a nome “Scegli il file di un tema per creare i tuoi moduli” una volta selezionato il foglio di stile dal menu a cascata e premuto il pulsante “Seleziona lo stile >>” non accade nulla, cioè rimane selezionato lo stile in uso?

      b. Hai inavvertitamente premuto il pulsante “Disattiva tutti i fogli di stile CSS”?

      c. verifica (via FTP) i permessi chmod per la sotto-cartella “styling” di cformsII (imposta a 755)

      Fammi sapere…

      Gianni

      • Gianluca 14 aprile 2010, 15:23

        a. Esattamente così come descrivi tu “Seleziona lo stile” e non accade nulla, ho provato anche su diversi fogli di stile. Non cambia nulla.
        b. Ho verificato e sono attivi
        c. Verificato anche questi e sono a posto

        Resta un po’ un mistero, anche perchè inizialmente dallo stile scelto mi ha permesso di effettuare delle modifiche (ad esempio ho cambiato il colore di sfondo). Ma da un certo punto in avanti ogni modifica non è stata più considerata. E anche il cambio di stile non ha effetto. Insomma lo stile pare essersi “congelato” alla prima modifica che ho fatto.

        In quale file il plugin scrive il nome del foglio attivo? Forse andando a toccare il file…
        è possibile come soluzione?
        Grazie
        Gianluca

        • gidibao 14 aprile 2010, 23:17

          Ciao Gianluca,

          hai forse attivato la funzione “Includi nella header i dati di cforms solamente per alcune pagine specifiche” (sotto Bacheca/cformsII/Impostazioni generali)? Se sì, disattivala e vedi se gli stili fossero nuovamente disponibili.

          Il tuo tema dispone di wp_head(); (Action Hook Template Tag) nel file header.php?

          Fammi sapere…

          • Gianluca 15 aprile 2010, 13:53

            Era attivata! L’avevo attivata per capire cosa implicasse e poi ero convinto di averla disattivata, evidentemente non avevo salvato le impostazioni.
            Grazie mille !!!!

  • Gianluca 12 aprile 2010, 20:13

    Ciao Gianni,
    anch’io ti ringrazio, la tua traduzione è ottima e anche i tuoi consigli.
    Ho una domanda: c’è predisposta qualche funzione in cforms che permetta di inserire un campo dove l’utente debba reinserire la sua mail una seconda volta (come si trova comunemente in molti form) e che verifichi che la seconda digitazione sia uguale alla prima?
    L’utilità, evidente, è quella di impedire che l’utente sbagli il suo indirizzo e per questo non si accorga di non essersi registrato
    Grazie
    Gianluca

    • gidibao 13 aprile 2010, 18:33

      Ciao Gianluca,

      purtroppo per il momento la funzione da te indicata non é disponibile.

      Prova ad aggiungere al modulo di contatto un nuovo campo indirizzo email (obbligatorio) oppure fai qualche test con il plugin Fast and Secure Contact Form (qui in italiano) che al contrario di cfII permette la verifica dell’indirizzo email.

      Fammi sapere…

      Gianni

      PS
      Grazie per il prezioso feedback! ;-)

      • Gianluca 14 aprile 2010, 15:30

        grazie, penso che per ora rinuncio a questa opzione. Non voglio rinunciare alle ottime carattiristiche di cforms (sempre se si sblocca la situazione dello stile di cui al post successivo!!!)
        Come palliativo per il discorso email, i miei utenti saranno avvisati di attendersi una mail di conferma, in caso contrario sono invitati a ricontattarmi.
        Grazie comunque

        • gidibao 14 aprile 2010, 23:20

          Prego, di nulla! :-)

          Ottima soluzione

  • marco 16 marzo 2010, 8:55

    Ah ok. Grazie per le preziosissime informazioni Gidibao!
    E ancora complimenti per il tuo lavoro

    ciaoo

    • gidibao 16 marzo 2010, 23:16

      Grazie a te per le visite e per i complimenti! ;-)

  • marco 15 marzo 2010, 19:16

    cavoli che peccato! Allora devo adattare il form alla pagina facendolo più grande. E non vorrei scocciarti troppo però… come si ingrandiscono i campi?
    ehehehehe, scusa poi prometto che non ti assillo più! :)

    • gidibao 15 marzo 2010, 19:50

      Nessun assillo marco! Figurati ;-)

      Purtroppo non é possibile rendere fluido (ossia adattare alla larghezza della pagina) il contenitore del modulo di contatto…

  • marco 15 marzo 2010, 10:16

    Ciao Gidibao! Sono nuovamente io con un altro piccolo problema di posizionamento di cforms.
    Se io volessi avere cforms sulla destra (e questo son riuscito a farlo) ma con un testo a sinistra?
    Mi succede infatti che il testo a sinistra si mette o sotto o sopra il cforms che ho piazzato a destra. Io invece li voglio appaiati.
    Come devo fare?

    Ringrazio anticipatamente perchè mi saprai sicuramente aiutare! :)

    • gidibao 15 marzo 2010, 18:48

      Ciao marco,

      non é possibile. Considera che sebbene il modulo abbia una dimensione più piccola rispetto al corpo dell’articolo/pagina ne occupa in estensione (in relazione alla propria larghezza ed altezza) tutta l’area. Difatti, hai potuto farlo scorrere dal centro alla destra come se lo avessi fatto scivolare… gli spazi al centro ed alla sinistra sono sempre suoi :-)

  • marco 14 marzo 2010, 12:01

    Ciao Gidibao,
    volevo farti una domanda forse semplice, ma non essendo un esperto ho alcune difficoltà: come faccio a impostare cforms in modo che finisca a destra in una pagina e non centrato? Non riesco proprio a spostarlo. Su che parametri devo mettere le mani?

    con l’occasione ti faccio i complimenti per il sito e per tutto! Grazie mille!

    • gidibao 14 marzo 2010, 13:53

      Ciao marco,

      affinché tu possa spostare a destra il modulo di contatto sarà necessario andare sotto Bacheca/cformsII/Stile, selezionare lo stile per il modulo in uso quindi, espandere l’”Editor CSS di base” (se già non lo fosse…).

      La classe CSS sulla quale dovrai operare é .cform.

      Ad esempio, ecco la classe .cform predefinita per il modulo “wide_open_big.css”:

      [css].cform {
      margin:10px auto 0 auto;
      width: 450px;
      }[/css]

      Ora, per portare l’allineamento del modulo alla destra, dovrai lavorare sulla proprietà a nome margin rimuovendo come prima cosa i valoriauto ed aggiungendo quindi un nuovo valore in px:

      [css].cform {
      margin:10px 350px;
      width: 450px;
      }[/css]

      Il valore “350″ é indicativo: sappi che lo spostamento a destra sarà direttamente proporzionale alla grandezza del numero… ad esempio, utilizzassi “450″ il modulo andrà più a destra che con “350″, etc.

      Ad operazione compiuta, ricordati di salvare le modifiche!

      Fammi sapere…

      Gianni

      • marco 14 marzo 2010, 18:20

        grazie mille!!!
        sei un geniooooo :)

        Complimenti ancora!

        • gidibao 14 marzo 2010, 19:03

          prego, di nulla! Sono molto lieto che la modifica abbia funzionato.

          Grazie a te per i complimenti ;-)

  • gidibao 10 marzo 2010, 20:11

    Ciao Marco,

    grazie per gli screenshot.
    Ho testato di nuovo il download con “Windows XP Professional” e con “Windows 7″: come prima, da me funzionano correttamente.

    Posso inviarti la cartella (non l’archivo) via email? L’indirizzo che hai inserito nel tuo commento va bene? (volessi che la email te la inviassi ad un indirizzo differente, nel tuo commento di risposta inserisci il nuovo indirizzo email).

    • Marco 22 marzo 2010, 14:41

      Ciao, scusami se rispondo solo ora ma sono stato all’estero alcune settimane. Il problema all’apertura dell’archivio persiste.
      Ti ringrazio molto per la tua disponbilità nell’inviarmi la cartella via mail, accetto molto volentieri.

      Grazie e ti auguro una buona giornata.

      • gidibao 22 marzo 2010, 17:33

        Ciao Marco,

        nessun problema… figurati! ;-)

        Grazie per l’info sull’archivio. Ti ho appena inviato via email tutti i file in italiano per cformsII.

        Buona giornata

        Gianni

  • Marco 10 marzo 2010, 15:14

    ciao, sono l’unico che non riesce ad aprire l’archivio contenente i files? winrar mi dice che potrebbe essere danneggiato…

  • Enrico 6 marzo 2010, 6:32

    Salve. Complimenti per i vostri suggerimenti.
    Ho installato sul mio blog fatto con Wordpress, il pluging ContactForm per la richiesta informazioni.
    Tutto bene, però … vorrei colorare i campi da riempire ??
    Dato che il template è su fondo bianco, a prima vista non si riconosce il campo dove scrivere i dati.
    Si accettano suggerimenti e consigli, grazie.

    A presto,
    Enrico

    • gidibao 6 marzo 2010, 14:34

      Ciao Enrico,

      il plugin cformsII offre la possibilità di utilizzare a propria scelta uno tra i venti stili disponibili sotto Bacheca/cformsII/Stile. Volendo, puoi crearne uno tutto nuovo oppure modificare a tuo piacere quelli già esistenti (via “Editor CSS di base”).

      Fammi sapere…

      Gianni

      PS
      Grazie per i complimenti.
      Link al tuo sito?

  • ANDREA 20 febbraio 2010, 9:46

    Grazie Gianni,
    mi fa molto piacere che il mio sito ti sia piaciuto… cmq accetto critiche… anzi :)

    Buon lavoro anche a te, a risentirci presto!

    Andrea

  • frankeyboard 19 febbraio 2010, 21:02

    Nessun problema a farti sapere quale è l’hosting Gianni. Sto facendo diverse installazioni con TMDHosting.com e devo dire che in quanto a servizio sono eccezionali: disponibilità 24/7 garantita anche se ovviamente si parla solo in inglese. Mi è capitato di aprire ticket a qls ora del giorno e della notte (domenica inclusa) e rispondono sempre entro 5-15 minuti.
    A livello di prezzi mi pare siano decisamente abbordabili. Unica pecca è quella di essere oltreoceano e quindi un po’ penalizzanti sui tempi di caricamento.

  • ANDREA 19 febbraio 2010, 1:31

    Ciao,
    volevo dirti che finalmente il mio sito è OnLine… ovviamente è ancora in fase di sistemazione… però se vuoi visionarlo e darmi eventualmente dei consigli ne sarei contento.
    Andrea

    Il sito è http://www.andrearinaldi82.it

    • gidibao 19 febbraio 2010, 12:47

      Ottima notizia Andrea! Grazie ;-)

      Così a prima vista, mi pare proprio che tu abbia fatto un ottimo lavoro di webmastering! Complimenti!!!

      Ad una seconda lettura, mi venisse in mente qualche suggerimento da proporti, ti contatterò privatamente via email.

      Happy Blogging

      Gianni

  • frankeyboard 17 febbraio 2010, 0:16

    Pare che ne siamo venuti a capo ma sinceramente non mi spiego come sia stato possibile…
    Andiamo per gradi. Il provider dice che dipende dallo script “/wp-content/plugins/cforms/lib_ajax.php” che va in Premature end of script headers.
    Pare che la cosa sia causata da un permesso 777 che non ਠsupportato dal piano di hosting (max 755).
    Il tecnico del supporto dice di aver semplicemente reimpostato a 755 la root e di conseguenza tutto quello che c’ਠsotto e le cose sono andate a posto.
    Ora non so quali possano essere le implicazioni ma, sta di fatto che il captcha ora va.
    Mi resterà  a vita il dubbio di come sia possibile che quello script avesse i permessi a 777 se il piano di hosting non li supporta.
    Mistero della fede.

    • gidibao 17 febbraio 2010, 0:44

      Interessante!!! A quale servizio di hosting ti appoggi? (naturalmente, rispondi solo se lo ritieni opportuno…)

      Sono comunque molto lieto che tu sia riuscito a risolvere il problema ;-)

  • frankeyboard 16 febbraio 2010, 19:56

    Mi sa che non dipende dalla GD. Il provider mi aveva già  detto che era attiva e il test lo conferma:

    GD Support enabled
    GD Version bundled (2.0.34 compatible)
    FreeType Support enabled
    FreeType Linkage with freetype
    FreeType Version 2.2.1
    GIF Read Support enabled
    GIF Create Support enabled
    JPG Support enabled
    PNG Support enabled
    WBMP Support enabled
    XPM Support enabled
    XBM Support enabled

    Seguo il tuo consiglio e provo a sentire cosa dice il provider.
    Ti tengo aggiornato e, comunque, grazie per i consigli.

    • gidibao 16 febbraio 2010, 23:37

      Prego… di nulla! Grazie a te frankeyboard per il feedback! ;-)

      Resto in attesa…

      Gianni

  • frankeyboard 14 febbraio 2010, 0:11

    Bingo!
    Mi sa che c’ਠqualche intoppo anche se a questo punto non so quale sia.
    Il test che mi hai suggerito rimanda ad una pagina che riporta il classico “Pagina non trovata”…

    Deduco che ci sia qualcosa da sistemare a livello di provider. Per la verità  ho la fortuna di avere un provider estremamente disponibile in questo senso: in genere basta chiedere e loro sistemano. Solo che non so cosa chiedere: quale requisito potrebbe essere stato non rispettato secondo te?

    PS: si, grazie, rimuovi i link dato che sono ancora in alto mare… :)

    • gidibao 14 febbraio 2010, 14:01

      Gli indizi condurrebbero alla libreria GD (serve per la creazione di immagini tramite PHP).

      Per verificare lo stato della “GD Library”, crea con un editor di testo del tipo Notepad++ un file a nome “test.php” (senza le virgolette!) inserendo in esso questa riga di codice:

      [php]<?php phpinfo(); ?>[/php]

      quindi, carica il file nella cartella principale del sito (allo stesso livello di “wp-content” per intenderci…).
      Ad operazione compiuta, apri il file via browser

      h t t p : / / nome-del-tuo-sito.com / test.php

      e verifica se il supporto GD sia attivo oppure no.

      (!)IMPORTANTE: una volta effettuata la verifica, rimuovi immediatamente il file “test.php” dalla cartella principale del sito!!!

      Al tuo fornitore di servizi di hosting potresti fare presente il fatto che le immagini per il CAPTCHA non vengono visualizzate (nonostante la libreria GD sia attiva oppure no a seconda dell’esito del test)…

      Nel caso in cui il problema non fosse risolvibile, “cformsII” ti permette di utilizzare come verifica anti-spam oltre al CAPTCHA anche la funzione “Domanda/Risposta”

      Fammi sapere l’esito del test (non inserire il link al file “test.php”!!!)…

      PS
      Sei su server Linux, vero?

  • frankeyboard 13 febbraio 2010, 22:12

    Una domanda che mi viene or ora: che tu sappia, non ci sarà  mica qualche impostazione particolare di mod_rewrite per le immagini del captcha o per lo script in generale?

    • gidibao 13 febbraio 2010, 22:42

      Ciao frankeyboard,

      a questo punto non vorrei che il problema dipendesse dal tuo webserver.

      Ti invito a fare questo test:

      1. installa il plugin Fast and Secure Contact Form

      2. attiva il programma

      3. sotto Bacheca/Plugin/SI Contact Form, vai alla voce “CAPTCHA:(form 1)”

      4. click sul link di testo: “Verifica se la tua installazione PHP sarà  in grado di supportare il CAPTCHA”

      Ad operazione compiuta, saprai con certezza se il tuo webserver sia in grado di supportare oppure no il CAPTCHA ;-)

      Fammi sapere l’esito del test… grazie.

      PS
      Complimenti per il sito! Mi piace molto ;-)

      Poiché il tuo nuovo sito é ancora in fase di allestimento, desideri che io rimuova il link a “CF Trattamenti”? Fammi sapere…

  • frankeyboard 13 febbraio 2010, 22:09

    Si, so del fatto che il captcha non lo vedo se sono loggato ma, quando sono loggato il captcha viene del tutto oscurato invece nel mio caso viene visualizzato solo che l’immagine ha una bella X rossa di immagine rotta (con IE – mentre con Firefox ho un buco).
    In ogni caso, non sono loggato quindi il problema non ਠquello.

    Come plugin ho solo Askimet e Attachmens ma quest’ultimo ਠdisattivato.

    Inoltre non sono in locale ma sul sito vero e proprio che ਠancora in costruzione…
    P.S. Grazie per la pazienza

  • frankeyboard 13 febbraio 2010, 1:08

    Chiedo scusa ma ho appena rilevato un’altra anomalia.
    A quanto pare ਠvero che gli altri campi funzionano ma il form sembrerebbe di no.
    In pratica ho eliminato il captcha per fare un test, riempio i campi obbligatori e non, premo invio ed appare il classico messaggio tipo “attendere prego…”.
    Solo che non succede nulla, il form resta congelato li.

    Forse questo da qualche indizio in pi�

    • gidibao 13 febbraio 2010, 13:45

      Ciao frankeyboard,

      stai forse testando il plugin in locale?

      Diversamente, potresti avere una qualche incompatibilità  con un altro (o pià¹) plugin. Prova a disattivare momentaneamente tutti i plugin e vedi cosa succede.

      Fammi sapere…

      PS
      Lo sapevi che quando sei loggato al tuo account WP il CAPTCHA non lo puoi vedere?

  • frankeyboard 13 febbraio 2010, 1:01

    La cosa strana ਠche tutto il resto funziona.
    E’ solo il campo tipo “captcha” che non gira a dovere.
    Sembra come se lo script individua immagini e font nella cartella ma poi non li riesce a trattare per renderizzare il captcha.

Next post:

Previous post: